Skip to main content
VulnerabilityPublished

CVE-2026-107308: Drupal Country · Cross-site Scripting

Affects Drupal CountrySource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 2.2.1 or 2.1.3 soon.

Data as of 30 Oct 2026, 04:15 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.2.1, 2.1.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Drupal Country to 2.2.1 or 2.1.3.

Affected software

ProductAffectedFixed in
DrupalCountryAffected
  • >=2.2.0 <2.2.1
Fixed in
  • 2.2.1
DrupalCountryAffected
  • <2.1.3
Fixed in
  • 2.1.3

AI-suggested

Upgrade affected Drupal Country module versions to 2.1.3 or 2.2.1 or later, where the vulnerability has been fixed. No other specific mitigation is indicated.

Description

CVE-2026-107308 is a Cross-Site Scripting (XSS) vulnerability in the Drupal Country module. It affects versions from 0.0.0 up to but not including 2.1.3, and from 2.2.0 up to but not including 2.2.1. The vulnerability arises from improper neutralization of input during web page generation, allowing attackers to inject malicious scripts. Fixed versions 2.1.3 and 2.2.1 address this issue.

References

Community reviews

Loading reviews…