Skip to main content
VulnerabilityPublished

CVE-2026-109243: FreeRDP · Incorrect Permissions

Affects FreeRDPSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.1 Medium : upgrade to 3.32.0 when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
4.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.04.1
CNA (VulnCheck)CVSS 3.14.4
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.32.0
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade freerdp/FreeRDP to 3.32.0.

Affected software

ProductAffectedFixed in
GitHubfreerdp/FreeRDPpkg:github/freerdp/FreeRDPOther threatsAffected
  • =3.0.0
  • >=3.0.0 <3.32.0
Fixed in
  • 3.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in FreeRDP version 3.32.0 and later. Users should upgrade to version 3.32.0 or newer to resolve the incorrect permission assignment vulnerability. No other mitigation steps are indicated.

Description

FreeRDP versions from 3.0.0 before 3.32.0 have an incorrect permission assignment vulnerability. This flaw allows local users on multi-user Unix systems to read private keys that should be owner-only during soft-smartcard logon. The vulnerability arises because the private keys written by crypto_write_pem are not restricted properly, making them world-readable in a shared temporary directory.

References

Community reviews

Loading reviews…