CVE-2026-114525: Drupal ABC · Cross-site Scripting
Affects Drupal ABCSource CVE Database V5
Not known to be exploited : upgrade to 2.0.1 or 1.25.0 soon.
Data as of 30 Oct 2026, 04:14 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 2.0.1, 1.25.0
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal ABC to 2.0.1 or 1.25.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalABC | Affected
| Fixed in
|
| DrupalABC | Affected
| Fixed in
|
AI-suggested
Apply the official fixes by upgrading Drupal ABC to version 1.25.0 or later, or 2.0.1 or later. These versions contain patches that address the stored XSS vulnerability. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-114525 is a stored cross-site scripting (XSS) vulnerability in the Drupal ABC product. It affects versions from 0.0.0 up to but not including 1.25.0, and from 2.0.0 up to but not including 2.0.1. The vulnerability arises from improper neutralization of input during web page generation, allowing malicious scripts to be stored and executed in users' browsers. Fixed versions are 1.25.0 and 2.0.1.