Skip to main content
VulnerabilityPublished

CVE-2026-114528: Drupal Zero Point · Cross-site Scripting

Affects Drupal Zero PointSource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 2.0.1 or 1.30.0 soon.

Data as of 30 Oct 2026, 04:14 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.0.1, 1.30.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Drupal Zero Point to 2.0.1 or 1.30.0.

Affected software

ProductAffectedFixed in
DrupalZero PointAffected
  • >=2.0.0 <2.0.1
Fixed in
  • 2.0.1
DrupalZero PointAffected
  • <1.30.0
Fixed in
  • 1.30.0

AI-suggested

Users and administrators should upgrade Drupal Zero Point to version 1.30.0 or later, or 2.0.1 or later, where this vulnerability has been fixed. Applying these official fixes will mitigate the risk of stored XSS attacks related to this issue.

Description

CVE-2026-114528 is a stored cross-site scripting (XSS) vulnerability in the Drupal Zero Point product. It affects versions from 0.0.0 up to but not including 1.30.0, and from 2.0.0 up to but not including 2.0.1. The vulnerability arises from improper neutralization of input during web page generation, allowing malicious scripts to be stored and executed in users' browsers. Fixed versions are 1.30.0 and 2.0.1.

References

Community reviews

Loading reviews…