CVE-2026-114529: Drupal CSV Field · Cross-site Scripting
Affects Drupal CSV FieldSource CVE Database V5
Not known to be exploited : upgrade to 3.0.7 or 2.0.10 soon.
Data as of 30 Oct 2026, 04:02 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 3.0.7, 2.0.10
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal CSV Field to 3.0.7 or 2.0.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalCSV Field | Affected
| Fixed in
|
| DrupalCSV Field | Affected
| Fixed in
|
AI-suggested
Apply the official fixes by upgrading the Drupal CSV Field module to version 2.0.10 or later, or 3.0.7 or later, as these versions contain patches addressing this vulnerability.
Description
A stored cross-site scripting (XSS) vulnerability exists in the Drupal CSV Field module affecting versions from 0.0.0 up to but not including 2.0.10, and from 3.0.0 up to but not including 3.0.7. This vulnerability allows improper neutralization of input during web page generation, potentially enabling attackers to inject malicious scripts.