CVE-2026-116238: pgAdmin 4 · Improper Restriction of Excessive Authentication Attempts
Affects pgAdmin 4Source CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 9.19 soon.
Data as of 30 Oct 2026, 20:38 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 8.1 |
|---|---|---|
| CNA (PostgreSQL) | CVSS 4.0 | 9.2 |
- Patch
- Available – fixed in 9.19
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pgAdmin 4 to 9.19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pgadmin.orgpgAdmin 4 | Affected
| Fixed in
|
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in pgAdmin 4 version 9.19 that addresses this vulnerability by enforcing proper counting and locking of failed login attempts, restricting password reset functionality, and securing authentication flows. Users should upgrade to version 9.19 or later. No additional mitigation is required if the fix is applied.
Description
CVE-2026-116238 is a vulnerability in pgAdmin 4 server mode before version 9.19 that allows bypassing the limit on failed login attempts for internal accounts. This flaw enables an unauthenticated attacker to make unlimited password guesses against internal accounts, including administrator accounts, due to improper handling of authentication attempts and password reset processes. The issue arises from the coexistence of Flask-Security views and pgAdmin's own authentication logic, case-insensitive username matching, and interactions with other authentication sources like LDAP and Kerberos. The vulnerability does not affect desktop mode and has been fixed in version 9.19.
References
- github.com/pgadmin-org/pgadmin4/issues/10676 (opens in a new tab)
- github.com/pgadmin-org/pgadmin4/commit/58c531d831179dc9b0a5bf873ccb80c71c8d387a (opens in a new tab)
- github.com/pgadmin-org/pgadmin4/commit/35c9235d17a7d5a99778f01b2f1b9e5e3a3b7fde (opens in a new tab)
- github.com/pgadmin-org/pgadmin4/commit/c6ef41a951012cd877a1992b5dac681eec36e48d (opens in a new tab)