Skip to main content
VulnerabilityPublished

CVE-2026-118243: highcharts · Prototype Pollution

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.2.2 when convenient.

Data as of 28 Oct 2026, 17:57 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts to 4.2.2.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • >=1.0.0 <4.2.2
Fixed in
  • 4.2.2
npmhighchartspkg:npm/highchartsOther threatsAffected
  • >=1.0.0 <4.2.2
Fixed in
  • 4.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Highcharts JS to version 4.2.2 or later, where this prototype pollution vulnerability is fixed. No other mitigation is indicated or required according to the vendor advisory information.

Description

CVE-2026-118243 is a prototype pollution vulnerability in Highcharts JS versions from 1.0.0 up to but not including 4.2.2. The issue arises because Highcharts Dashboards stores DataCursor listener and state maps in plain objects keyed by DataTable ID. If an attacker supplies a __proto__ table ID via the dataPool connector configuration, it modifies Object.prototype, creating enumerable properties that affect all objects. This can disrupt features such as extremes synchronization. Exploitation requires untrusted dashboard configuration and enabled component sync, but no user interaction beyond loading the dashboard is needed. The vulnerability is fixed in version 4.2.2.

References

Community reviews

Loading reviews…