CVE-2026-118248: highcharts · Prototype Pollution
Affects highchartsSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 13.1.0 when convenient.
Data as of 28 Oct 2026, 18:28 UTC
- Patch
- Available – fixed in 13.1.0, 4.2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:H/VA:H/SC:L/SI:L/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade highcharts to 13.1.0; dashboards to 4.2.2; highcharts/highcharts to 13.1.0 or 4.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| highchartshighcharts | Affected
| Fixed in
|
| @highchartsdashboards | Affected
| Fixed in
|
npmhighcharts/highchartspkg:npm/highcharts/highchartsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Highcharts versions 4.2.2 and 13.1.0. Users should upgrade to one of these versions or later to remediate the issue. No additional mitigations are indicated by the vendor advisory.
Description
CVE-2026-118248 is a prototype pollution vulnerability in Highcharts JS versions from 1.0.0 up to but not including 4.2.2. The issue arises in Highcharts Dashboards edit mode where the editableOptions propertyPath segments do not reject prototype-related keys such as __proto__ or constructor. An attacker controlling editableOptions can exploit this to write values onto Object.prototype, affecting JavaScript behavior throughout the page. This vulnerability is fixed in versions 4.2.2 and 13.1.0.