Skip to main content
VulnerabilityPublished

CVE-2026-118256: intlify vue-i18n · Cross-site Scripting

Affects intlify vue-i18nSource CVE Database V5

0

Not known to be exploited · CVSS 2.1 Low : upgrade to 12.0.0-alpha.5 or 11.4.14 when convenient.

Data as of 28 Oct 2026, 18:58 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 12.0.0-alpha.5, 11.4.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade intlify vue-i18n to 12.0.0-alpha.5 or 11.4.14.

Affected software

ProductAffectedFixed in
intlifyvue-i18nAffected
  • >=12.0.0-alpha.1 <12.0.0-alpha.5
Fixed in
  • 12.0.0-alpha.5
intlifyvue-i18nAffected
  • >=9.0.0-beta.5 <11.4.14
Fixed in
  • 11.4.14
npmvue-i18npkg:npm/vue-i18nOther threatsAffected
  • >=9.0.0-beta.5 <11.4.14
  • >=12.0.0-alpha.1 <12.0.0-alpha.5
Fixed in
  • 11.4.14
  • 12.0.0-alpha.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to vue-i18n versions 11.4.14 or later, or 12.0.0-alpha.5 or later, where this vulnerability is fixed. There are no vendor advisories indicating that no action is required or that the issue is already mitigated in earlier versions. Applying the official fix is the recommended remediation.

Description

A cross-site scripting (XSS) vulnerability exists in the vue-i18n internationalization plugin for Vue.js versions from 9.0.0-beta.5 up to but not including 11.4.14 and from 12.0.0-alpha.1 up to but not including 12.0.0-alpha.5. When the escapeParameter (escapeParameterHtml in the Legacy API) option is enabled, named interpolation values are not properly escaped if both list and named values are supplied in the same translation call. This can allow attacker-controlled HTML markup injection, potentially leading to phishing or script execution when combined with other issues. The vulnerability is fixed in versions 11.4.14 and 12.0.0-alpha.5.

References

Community reviews

Loading reviews…