Skip to main content
VulnerabilityPublished

CVE-2026-118257: intlify vue-i18n · Cross-site Scripting

Affects intlify vue-i18nSource CVE Database V5

0

Not known to be exploited · CVSS 7.2 High : upgrade to 12.0.0-alpha.5 or 11.4.14 soon.

Data as of 28 Oct 2026, 18:58 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 12.0.0-alpha.5, 11.4.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade intlify vue-i18n to 12.0.0-alpha.5 or 11.4.14.

Affected software

ProductAffectedFixed in
intlifyvue-i18nAffected
  • >=11.1.10 <11.4.14
  • >=12.0.0-alpha.4 <12.0.0-alpha.5
  • =9.14.5
  • =10.0.8
Fixed in
  • 12.0.0-alpha.5
  • 11.4.14
npmvue-i18npkg:npm/vue-i18nOther threatsAffected
  • =9.14.5
  • =10.0.8
  • >=11.1.10 <11.4.14
  • >=12.0.0-alpha.4 <12.0.0-alpha.5
Fixed in
  • 11.4.14
  • 12.0.0-alpha.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected vue-i18n versions to 11.4.14 or later, or 12.0.0-alpha.5 or later, where the vulnerability is fixed. Applications should avoid enabling escapeParameter with rendering translations as HTML through v-html until patched. No other mitigations are specified by the vendor advisory.

Description

CVE-2026-118257 is a high-severity cross-site scripting (XSS) vulnerability in the vue-i18n internationalization plugin for Vue.js. The flaw affects versions 9.14.5, 10.0.8, and versions from 11.1.10 up to but not including 11.4.14, as well as 12.0.0-alpha.4 up to but not including 12.0.0-alpha.5. The vulnerability arises because the sanitizeTranslatedHtml() function escapes markup and event-handler text inside an iframe srcdoc attribute but leaves the srcdoc attribute active, allowing browsers to parse attacker-controlled content as same-origin nested HTML. This can lead to script execution when escapeParameter is enabled and translations are rendered as HTML via v-html. The issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.

References

Community reviews

Loading reviews…