GFI KerioConnect (Kerio Connect) before 10.0.9 Patch 2 contains a cross-site scripting vulnerability in the Webmail
Source GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 10.0.9p2 when convenient.
Data as of 28 Oct 2026, 20:12 UTC
- Patch
- Available – fixed in 10.0.9p2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade GFI KerioConnect to 10.0.9p2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GFI USA, LLCGFI KerioConnect | Affected
| Fixed in
|
AI-suggested
A fix is available in GFI KerioConnect version 10.0.9 Patch 2. Users should upgrade to this version or later to remediate the vulnerability. No additional vendor advisory content is provided, so patching is the primary recommended mitigation.
Description
GFI KerioConnect versions before 10.0.9 Patch 2 contain a cross-site scripting (XSS) vulnerability in the Webmail component. This flaw allows a remote attacker to inject malicious HTML or script into a victim's authenticated Webmail session by sending a specially crafted email. The vulnerability arises from the link auto-formatter re-processing already-linked text and improperly handling quote characters, enabling script execution within the victim's session.