CVE-2026-118642: n8n · Incorrect Authorization
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.123.85 when convenient.
Data as of 28 Oct 2026, 19:27 UTC
- Patch
- Available – fixed in 1.123.85, 2.44.1, 2.43.5
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions 1.123.85, 2.43.5, and 2.44.1 are available and should be applied to remediate this vulnerability. Users should upgrade to these versions to ensure the authorization bypass flaw is resolved.
Description
n8n versions before 1.123.85, 2.43.5, and 2.44.1 contain an authorization bypass vulnerability. This flaw allows authenticated users to access credentials they should not have permission to use by exploiting inline sub-workflow nodes with non-boolean disabled values. Attackers who know a credential ID can run Execute Workflow nodes in inline JSON mode to bypass permission checks and exfiltrate decrypted credentials to attacker-controlled servers.