CVE-2026-12584: Payment Gateway for Redsys & WooCommerce Lite (WordPress plugin) · Insufficient Verification of Data Authenticity
Affects Payment Gateway for Redsys & WooCommerce Lite (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 7.0.2 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Payment Gateway for Redsys & WooCommerce Lite (WordPress plugin) to 7.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Payment Gateway for Redsys & WooCommerce Lite | Affected
| Fixed in
|
Description
The Payment Gateway for Redsys & WooCommerce Lite WordPress plugin versions before 7.0.2 contains a vulnerability where it does not verify the authenticity of incoming payment-provider notifications. This flaw allows unauthenticated attackers to forge payment-confirmation callbacks and mark orders as paid without actual payment. The vulnerability is identified as CWE-345 (Insufficient Verification of Data Authenticity) and has a CVSS 3.1 score of 7.5, indicating high severity.