Skip to main content
VulnerabilityPublished Updated

CVE-2026-15890: zephyrproject zephyr · Crypto

Affects zephyrproject zephyrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.4.2 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.07% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.2
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade zephyrproject zephyr to 4.4.2.

Affected software

ProductAffectedFixed in
zephyrprojectzephyrAffected
  • >=4.0.0 <4.4.2
Fixed in
  • 4.4.2
GitHubzephyrpkg:github/zephyrOther threatsAffected
  • >=4.0.0 <4.4.2
Fixed in
  • 4.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available that serializes nonce generation using a mutex to prevent race conditions and nonce reuse. Users should upgrade to Zephyr version 4.4.2 or later where this issue is resolved. Until patched, avoid concurrent writes to the same UID in the ITS to mitigate the risk.

Description

CVE-2026-15890 is a medium severity vulnerability in the Zephyr project affecting versions 4.0.0 up to but not including 4.4.2. It involves a race condition in the default AEAD nonce provider for the PSA Internal Trusted Storage (ITS) transform module, where nonce counters are stored in unsynchronized static variables. Concurrent writes to the same UID can cause nonce reuse with AES-GCM or ChaCha20-Poly1305 encryption, leading to catastrophic cryptographic failures such as plaintext leakage and authentication key exposure. The vulnerability requires an application writing concurrently to the same UID from multiple threads and the presence of raw storage access to exploit. The fix involves serializing nonce generation with a mutex to prevent race conditions.

References

Community reviews

Loading reviews…