Skip to main content
VulnerabilityPublished

CVE-2026-17054: zephyrproject zephyr · Bounds

Affects zephyrproject zephyrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.4.2 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.2
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade zephyrproject zephyr to 4.4.2.

Affected software

ProductAffectedFixed in
zephyrprojectzephyrAffected
  • >=4.2.0 <4.4.2
Fixed in
  • 4.4.2
GitHubzephyrpkg:github/zephyrOther threatsAffected
  • >=4.2.0 <4.4.2
Fixed in
  • 4.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, affected devices may require manual reboot after a denial of service occurs.

Description

CVE-2026-17054 is a vulnerability in the Espressif ESP-hosted Wi-Fi driver within the Zephyr project. It involves improper bounds checking of a 16-bit TLV data_length field parsed from SPI frames, leading to out-of-bounds reads of up to approximately 62 KB past a stack object. This can cause device faults and denial of service due to heap allocations and thread blocking. The vulnerability affects Zephyr versions from 4.2.0 up to but not including 4.4.2. The impact is limited to denial of service without data disclosure. There is no indication of an official patch or vendor advisory in the provided data.

References

Community reviews

Loading reviews…