Skip to main content
VulnerabilityPublished

CVE-2026-1867: Guest posting / Frontend Posting / Front Editor (WordPress plugin) · Information Exposure

Affects Guest posting / Frontend Posting / Front Editor (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 5.0.6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.6
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Guest posting / Frontend Posting / Front Editor (WordPress plugin) to 5.0.6.

Affected software

ProductAffectedFixed in
Guest posting / Frontend Posting / Front EditorAffected
  • <5.0.6
Fixed in
  • 5.0.6

AI-suggested

  1. Immediate mitigation should focus on restricting access to the vulnerable plugin functionality by implementing web application firewall (WAF) rules that block requests containing the specific URL parameter used to regenerate the .json file.
  2. Disable or restrict the Guest posting / Frontend Posting / Front Editor plugin if it is not essential to site operations until a patched version is released.
  3. Monitor web server logs for suspicious requests targeting the .json regeneration endpoint to detect potential exploitation attempts.
  4. Limit administrative privileges and avoid enabling admin notifications in the plugin settings unless necessary.
  5. Once available, promptly update the plugin to version 5.0.6 or later that addresses this vulnerability.
  6. Consider implementing additional access controls such as IP whitelisting or authentication requirements for accessing sensitive plugin features.
  7. Educate site administrators about phishing risks stemming from exposed email addresses and encourage use of multifactor authentication to protect accounts.
  8. Regularly audit WordPress plugins for security updates and vulnerabilities to maintain a secure environment. These steps go beyond generic advice by focusing on immediate access restriction, monitoring, and administrative best practices tailored to this specific vulnerability.

Description

The Guest posting / Frontend Posting / Front Editor WordPress plugin before 5.0.6 allows passing a URL parameter to regenerate a .json file based on demo data that it initially creates. If an administrator modifies the demo form and enables admin notifications in the Guest posting / Frontend Posting / Front Editor WordPress plugin before 5.0.6's settings, it is possible for an unauthenticated attacker to export and download all of the form data/settings, including the administrator's email address.

References

Community reviews

Loading reviews…