Skip to main content
CVE-2026-2003VulnerabilityPublished

CVE-2026-2003: PostgreSQL · Improper Validation of Specified Type of Input

Affects PostgreSQLSource CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium · fixed in 18.2 : update PostgreSQL when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.2, 17.8, 16.12 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.2
  • >=17 <17.8
  • >=16 <16.12
  • >=15 <15.16
  • <14.21
Fixed in
  • 18.2
  • 17.8
  • 16.12
  • 15.16
  • 14.21

AI-suggested

Organizations should promptly upgrade affected PostgreSQL instances to the fixed versions: 18.2, 17.8, 16.12, 15.16, or 14.21 or later. If you cannot patch yet, restrict database access to trusted users only and enforce the principle of least privilege to minimize the number of users who can exploit this vulnerability. Monitor database logs for unusual queries or access patterns involving the 'oidvector' type or suspicious input data. Employ network segmentation and firewall rules to limit external access to PostgreSQL servers. Consider implementing database activity monitoring solutions to detect anomalous behavior. If patching is delayed, review application code and database roles to ensure that untrusted users cannot execute queries involving the vulnerable input type. Regularly audit user privileges and rotate credentials to reduce the risk of compromised accounts being used to exploit this flaw. Stay informed through official PostgreSQL security advisories for any additional guidance or patches.

Description

Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory. We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they seem unlikely. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

References

Community reviews

Loading reviews…