Skip to main content
CVE-2026-2006VulnerabilityPublished Updated

CVE-2026-2006: PostgreSQL · Improper Validation of Array Index

Affects PostgreSQLSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 18.2 : patch PostgreSQL soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.2, 17.8, 16.12 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.2
  • >=17 <17.8
  • >=16 <16.12
  • >=15 <15.16
  • <14.21
Fixed in
  • 18.2
  • 17.8
  • 16.12
  • 15.16
  • 14.21

AI-suggested

Official patches addressing CVE-2026-2006 are available from Red Hat for affected PostgreSQL versions. Users should apply the security updates provided in the referenced Red Hat advisories (e.g., RHSA-2026:4441) to remediate this vulnerability. Patch status is confirmed by vendor advisories. No alternative mitigations or workarounds are specified in the advisory; applying the official fix is the recommended action.

Description

Missing validation of multibyte character length in PostgreSQL text manipulation allows a database user to issue crafted queries that achieve a buffer overrun. That suffices to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

References

Community reviews

Loading reviews…