CVE-2026-21444: stefanberger libtpms · Weak Cryptography
Affects stefanberger libtpmsSource CVE Database V5
Not known to be exploited · CVSS 5.5 Medium : upgrade to 0.10.2 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.08% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.10.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade stefanberger libtpms to 0.10.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| stefanbergerlibtpms | Affected
| Fixed in
|
GitHubstefanberger/libtpmspkg:github/stefanberger/libtpmsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should promptly upgrade libtpms to version 0.10.2 or later to remediate the vulnerability. Since no workarounds exist, patching is the primary defense. Additionally, organizations should audit systems using libtpms to identify affected versions and restrict local access to trusted users only. Implementing strict access controls and monitoring for unusual local activity can reduce exploitation risk. Regular cryptographic audits and validation of TPM emulation implementations can help detect similar weaknesses. Finally, organizations should maintain up-to-date inventories of cryptographic libraries and dependencies to facilitate rapid response to vulnerabilities.
Description
libtpms, a library that provides software emulation of a Trusted Platform Module, has a flaw in versions 0.10.0 and 0.10.1. The commonly used integration of libtpms with OpenSSL 3.x contained a vulnerability related to the returned IV (initialization vector) when certain symmetric ciphers were used. Instead of returning the last IV it returned the initial IV to the caller, thus weakening the subsequent encryption and decryption steps. The highest threat from this vulnerability is to data confidentiality. Version 0.10.2 fixes the issue. No known workarounds are available.