Skip to main content
CVE-2026-21896VulnerabilityPublished

CVE-2026-21896: getkirby kirby · Incorrect Authorization

Affects getkirby kirbySource CVE Database V5

0

Not known to be exploited · CVSS 5.8 Medium : upgrade to 5.2.2 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.2.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade kirby and getkirby/kirby to 5.2.2.

Affected software

ProductAffectedFixed in
getkirbykirbyAffected
  • >=5.0.0 <5.2.2
Fixed in
  • 5.2.2
GitHubgetkirby/kirbypkg:github/getkirby/kirbyOther threatsAffected
  • <5.2.2 >=5.0.0
Fixed in
  • 5.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade all Kirby CMS installations to version 5.2.2 or later, where the authorization checks have been properly implemented. Organizations should audit their current Kirby versions and prioritize patching those within the affected range (>=5.0.0 and <5.2.2). Additionally, review and tighten user role configurations to minimize unnecessary write permissions and ensure that roles are assigned following the principle of least privilege. Implement monitoring and alerting on content changes to detect unauthorized modifications promptly. Employ web application firewalls (WAFs) with custom rules to detect anomalous API requests targeting content changes endpoints. Conduct regular security assessments and penetration testing focusing on CMS authorization controls. Finally, maintain an inventory of CMS instances and enforce strict update policies to reduce exposure to known vulnerabilities.

Description

Kirby is an open-source content management system. From versions 5.0.0 to 5.2.1, Kirby is missing permission checks in the content changes API. This vulnerability affects all Kirby sites where user permissions are configured to prevent specific role(s) from performing write actions, specifically by disabling the update permission with the intent to prevent modifications to site content. This vulnerability does not affect those who have not altered the deviated from default user permissions. This issue has been patched in version 5.2.2.

References

Community reviews

Loading reviews…