Skip to main content
VulnerabilityPublished

CVE-2026-22182: gVectors wpDiscuz · Missing Authorization

Affects gVectors wpDiscuzSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 7.6.47 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gVectors wpDiscuz to 7.6.47.

Affected software

ProductAffectedFixed in
gVectorswpDiscuzAffected
  • <7.6.47
Fixed in
  • 7.6.47

AI-suggested

To mitigate CVE-2026-22182, organizations should immediately update the wpDiscuz plugin to version 7.6.47 or later, where the vulnerability is patched. If immediate patching is not feasible, administrators should implement temporary controls such as: 1) Restricting access to the wpdiscuz-ajax.php endpoint via web application firewall (WAF) rules or IP rate limiting to prevent abuse. 2) Enabling or enforcing CAPTCHA challenges on comment and notification-related AJAX requests to deter automated exploitation. 3) Monitoring outgoing email traffic for unusual spikes in notification emails and alerting on anomalies. 4) Reviewing and tightening WordPress user permissions and plugin configurations to minimize exposure. 5) Employing email rate limiting and spam filtering at the mail server level to reduce impact on recipients. Additionally, plugin developers and site administrators should audit other AJAX endpoints for similar missing authorization or nonce verification issues to prevent future vulnerabilities.

Description

CVE-2026-22182 is a high-severity unauthenticated denial of service vulnerability in the gVectors wpDiscuz plugin before version 7.6.47. The flaw allows anonymous attackers to exploit the checkNotificationType() function by repeatedly calling the wpdiscuz-ajax.php endpoint with arbitrary postId and comment_id parameters. This triggers mass notification emails to subscribers without any nonce verification, authentication, or rate limiting, resulting in email flooding. The vulnerability has a CVSS 4.0 score of 8.7, indicating a critical impact on availability with no user interaction or privileges required. No known exploits are currently reported in the wild.

References

Community reviews

Loading reviews…