CVE-2026-22193: wpDiscuz (WordPress plugin) · SQL Injection
Affects wpDiscuz (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.2 Critical : upgrade to 7.6.47 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade wpDiscuz (WordPress plugin) to 7.6.47.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gVectorswpDiscuz | Affected
| Fixed in
|
AI-suggested
Organizations should immediately upgrade wpDiscuz to version 7.6.47 or later once available, as this will contain the official fix for the SQL injection vulnerability. If you cannot patch yet, web administrators should implement Web Application Firewall (WAF) rules to detect and block suspicious SQL injection payloads targeting the vulnerable parameters (email, activation_key, subscription_date, imported_from). Input validation and sanitization should be enforced at the application level to reject malformed or unexpected input. Monitoring database query logs for unusual patterns can help detect exploitation attempts early. Restricting database user permissions to the minimum necessary can limit the impact of a successful injection. Additionally, organizations should review backup and recovery procedures to ensure rapid restoration in case of data tampering. Regular security audits of WordPress plugins and dependencies are recommended to identify and mitigate similar risks proactively.
Description
CVE-2026-22193 is a critical SQL injection vulnerability in the wpDiscuz WordPress plugin before version 7.6.47. The flaw exists in the getAllSubscriptions() function, where certain string parameters (email, activation_key, subscription_date, imported_from) are not properly escaped, allowing attackers to inject malicious SQL code. Exploitation requires no authentication or user interaction and can lead to full compromise of database confidentiality, integrity, and availability. The vulnerability has a CVSS 4.0 score of 9.2, indicating critical severity. Although no known exploits are currently reported in the wild, the ease of exploitation and impact make it a significant threat to websites using affected versions of wpDiscuz. Organizations should prioritize patching or applying mitigations immediately to prevent data breaches and potential site compromise.