Skip to main content
VulnerabilityPublished

CVE-2026-22202: wpDiscuz (WordPress plugin) · Cross-Site Request Forgery (CSRF)

Affects wpDiscuz (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 7.6.47 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade wpDiscuz (WordPress plugin) to 7.6.47.

Affected software

ProductAffectedFixed in
gVectorswpDiscuzAffected
  • <7.6.47
Fixed in
  • 7.6.47

AI-suggested

Organizations should immediately update wpDiscuz to version 7.6.47 or later, where this vulnerability is patched. If you cannot patch yet, administrators can implement web application firewall (WAF) rules to block suspicious GET requests containing the deletecomments action or HMAC parameters. Additionally, disabling or restricting the deletecomments functionality to authenticated users with proper CSRF tokens and enforcing POST-only methods for state-changing actions can mitigate exploitation. Site owners should audit comment deletion logs for suspicious activity and educate users about avoiding clicking untrusted links. Implementing Content Security Policy (CSP) headers to restrict embedding of malicious resources and monitoring for unusual traffic patterns targeting comment deletion endpoints can also help. Finally, plugin developers should adopt secure coding practices that enforce strict CSRF protections and avoid using GET requests for destructive actions.

Description

CVE-2026-22202 is a cross-site request forgery (CSRF) vulnerability in the wpDiscuz WordPress plugin before version 7.6.47. This flaw allows attackers to delete all comments associated with a specific email address by sending a crafted GET request containing a valid HMAC key. The vulnerability arises because the deletecomments action can be triggered via image tags or other embedded resources without requiring POST-based CSRF protections or user confirmation. Exploitation does not require authentication but does require user interaction, such as visiting a malicious webpage. The CVSS 4.0 score is 6.1 (medium severity), reflecting the moderate impact on comment integrity and availability but no direct compromise of confidentiality or site control. No known exploits are currently in the wild.

References

Community reviews

Loading reviews…