Skip to main content
VulnerabilityPublished

CVE-2026-22203: wpDiscuz (WordPress plugin) · Information Exposure

Affects wpDiscuz (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.6.47 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade wpDiscuz (WordPress plugin) to 7.6.47.

Affected software

ProductAffectedFixed in
gVectorswpDiscuzAffected
  • <7.6.47
Fixed in
  • 7.6.47

AI-suggested

To mitigate CVE-2026-22203, organizations should immediately update wpDiscuz to version 7.6.47 or later where this vulnerability is addressed. Administrators should audit all exported plugin option files, support tickets, backups, and version control repositories for any plaintext OAuth secrets and rotate these credentials if they have been exposed. Implement strict access controls and encryption for any exported configuration files to prevent unauthorized access. Limit the number of administrators who can export plugin options and enforce least privilege principles. Additionally, monitor social login provider dashboards for suspicious activity that could indicate misuse of compromised secrets. Educate administrators about the risks of exporting sensitive configuration data and establish secure handling procedures. Finally, consider implementing multi-factor authentication on social login provider accounts to reduce the impact of credential exposure.

Description

CVE-2026-22203 is an information disclosure vulnerability in the wpDiscuz WordPress plugin before version 7.6.47. It allows administrators to inadvertently expose sensitive OAuth secrets such as Facebook App Secret, Google Client Secret, and Twitter App Secret by exporting plugin options as JSON. Attackers can obtain these plaintext API credentials from exported files found in support tickets, backups, or version control repositories. The vulnerability does not require user interaction but requires administrator privileges to trigger the export. The CVSS 4.0 base score is 6.9, indicating a medium severity level. Exploitation could lead to unauthorized access to social login integrations, potentially compromising user authentication and privacy.

References

Community reviews

Loading reviews…