Skip to main content
VulnerabilityPublished

CVE-2026-22204: gVectors wpDiscuz · Improper Input Validation

Affects gVectors wpDiscuzSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 7.6.47 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gVectors wpDiscuz to 7.6.47.

Affected software

ProductAffectedFixed in
gVectorswpDiscuzAffected
  • <7.6.47
Fixed in
  • 7.6.47

AI-suggested

Organizations should immediately verify their wpDiscuz plugin version and upgrade to version 7.6.47 or later once available to address this vulnerability. If you cannot patch yet, administrators can implement strict input validation and sanitization on the comment_author_email cookie to reject or neutralize suspicious characters that could enable header injection (e.g., newline characters, carriage returns). Web application firewalls (WAFs) can be configured to detect and block malicious cookie payloads targeting email headers. Monitoring outgoing emails for unusual recipient patterns or unexpected headers can help identify exploitation attempts. Additionally, restricting the use of wp_mail() to trusted inputs and employing email sending libraries that automatically sanitize headers can reduce risk. Regular security audits and vulnerability scanning focused on WordPress plugins are recommended to detect similar issues proactively. Finally, educating site administrators about the risks of email header injection and maintaining timely updates of all plugins is essential.

Description

CVE-2026-22204 is an email header injection vulnerability in gVectors wpDiscuz versions before 7.6.47. The flaw arises from improper input validation of the comment_author_email cookie, which attackers can manipulate to inject malicious data. This data is processed via urldecode() and passed to wp_mail(), enabling attackers to alter email recipients or add unauthorized email headers. Exploitation does not require authentication or user interaction, and the vulnerability has a CVSS score of 6.3 (medium severity). While no known exploits are currently observed in the wild, the vulnerability could be leveraged to facilitate spam, phishing, or email-based attacks. Organizations using vulnerable wpDiscuz versions should prioritize patching once available and implement input validation controls. The threat primarily affects websites using wpDiscuz, which is popular in countries with high WordPress usage.

References

Community reviews

Loading reviews…