CVE-2026-22210: wpDiscuz (WordPress plugin) · Cross-site Scripting
Affects wpDiscuz (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 2.1 Low : upgrade to 7.6.47 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade wpDiscuz (WordPress plugin) to 7.6.47.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gVectorswpDiscuz | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2026-22210, organizations should immediately upgrade wpDiscuz to version 7.6.47 or later where the vulnerability is fixed. If upgrading is not immediately possible, administrators should restrict the ability to upload or modify attachments and filter hooks to trusted users only, minimizing the attack surface. Implementing a Web Application Firewall (WAF) with rules to detect and block suspicious script injections in comment attachments can provide temporary protection. Site administrators should audit existing attachments and filters for suspicious or malformed URLs and remove any untrusted content. Enforcing Content Security Policy (CSP) headers can help limit the impact of injected scripts by restricting script sources. Regularly monitoring logs for unusual comment activity or user reports of suspicious behavior is recommended. Finally, educating site users about the risks of interacting with untrusted comments and maintaining updated backups will aid in recovery if exploitation occurs.
Description
CVE-2026-22210 is a cross-site scripting (XSS) vulnerability in the gVectors wpDiscuz WordPress plugin versions before 7.6.47. The flaw arises from improper neutralization of input during web page generation, specifically through unescaped attachment URLs processed by the WpdiscuzHelperUpload class. Attackers can inject malicious JavaScript code into img and anchor tag attributes by crafting malicious attachment records or filter hooks. This code executes in the context of WordPress users viewing comments, potentially leading to session hijacking or other client-side attacks. The vulnerability requires low privileges and user interaction but does not compromise confidentiality, integrity, or availability directly. No known exploits are reported in the wild, and the CVSS 4.0 score is low (2.1).