CVE-2026-22215: gVectors wpDiscuz · Cross-Site Request Forgery (CSRF)
Affects gVectors wpDiscuzSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 7.6.47 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade gVectors wpDiscuz to 7.6.47.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gVectorswpDiscuz | Affected
| Fixed in
|
AI-suggested
Organizations should immediately update wpDiscuz to version 7.6.47 or later, where the CSRF protection via nonce validation is implemented. If immediate patching is not feasible, administrators should consider disabling the follow feature or restricting access to the getFollowsPage() functionality through web application firewalls or custom access controls. Implementing Content Security Policy (CSP) headers and SameSite cookies can reduce the risk of CSRF attacks by limiting cross-origin requests. Monitoring web server logs for unusual requests to the follows page handler can help detect attempted exploitation. Educating users about phishing risks and avoiding clicking on suspicious links reduces the likelihood of successful user interaction-based attacks. Plugin developers should adopt secure coding practices, including consistent use of nonce validation for all state-changing requests. Regular security audits and vulnerability scanning of WordPress plugins are recommended to identify and remediate similar issues proactively.
Description
CVE-2026-22215 is a medium severity Cross-Site Request Forgery (CSRF) vulnerability affecting wpDiscuz versions prior to 7.6.47. The flaw exists in the getFollowsPage() function, which lacks nonce validation, allowing attackers to craft malicious requests that trigger unauthorized actions. Exploitation can lead to enumeration of user follow relationships and manipulation of follow data without user consent. No authentication or privileges are required, but user interaction is necessary to execute the attack. Although no known exploits are currently in the wild, the vulnerability poses a risk to websites using vulnerable wpDiscuz versions. Organizations should prioritize patching or applying mitigations to prevent unauthorized data manipulation and privacy breaches. The threat primarily affects WordPress sites globally, with heightened risk in countries with widespread WordPress adoption. The CVSS 4.