CVE-2026-22216: gVectors wpDiscuz · Improper Control of Interaction Frequency
Affects gVectors wpDiscuzSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.6.47 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade gVectors wpDiscuz to 7.6.47.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gVectorswpDiscuz | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2026-22216, organizations should immediately update wpDiscuz to version 7.6.47 or later once available, as this version addresses the missing rate limiting vulnerability. In the absence of an official patch, administrators should implement custom rate limiting on the wpdAddSubscription endpoint at the web server or application firewall level to restrict the frequency of subscription requests from the same IP address. Input validation should be enhanced to disallow SQL wildcard characters in email subscription requests to prevent mass matching of email addresses. Monitoring and alerting on unusual spikes in subscription activity can help detect exploitation attempts early. Additionally, implementing CAPTCHA or other challenge-response tests on subscription forms can reduce automated abuse. Reviewing email notification policies to limit the volume and frequency of notifications sent to users can mitigate the impact of potential abuse. Finally, educating users to recognize and report unsolicited notifications can aid in early detection and response.
Description
CVE-2026-22216 is a medium severity vulnerability in gVectors wpDiscuz versions before 7.6.47. It involves missing rate limiting on the subscription endpoint, allowing unauthenticated attackers to subscribe arbitrary email addresses to post notifications. Attackers can exploit LIKE wildcard characters in the subscription query to match multiple email addresses, causing unwanted notification emails to be sent to victims. This can lead to spam, user annoyance, and potential email service abuse. No authentication or user interaction is required, and the vulnerability affects the availability and integrity of email notification services. There are no known exploits in the wild yet, but the vulnerability is publicly disclosed. Organizations using vulnerable wpDiscuz versions should apply patches or implement mitigations promptly to prevent abuse. The threat primarily affects websites using wpDiscuz, which is popular in WordPress communities worldwide, especially in countries with high WordPress adoption.