Skip to main content
CVE-2026-22223VulnerabilityPublished Updated

CVE-2026-22223: TP-Link System Archer BE230 v1.2 · OS Command Injection

Affects TP-Link System Archer BE230 v1.2Source CVE Database V5

0

Not known to be exploited · CVSS 8.5 High : upgrade to 1.2.4 Build 20251218 rel.70420 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.4 Build 20251218 rel.70420, (USW)_V1.26_1.2.6 Build 20260617, (KR)_V1_1.2.2 Build 20260903 +1
CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Archer to 1.2.4 Build 20251218 rel.70420 (BE230 v1.2); (USW)_V1.26_1.2.6 Build 20260617, (KR)_V1_1.2.2 Build 20260903 or (EU)_V1_1.2.6 Build 20260617 (BE3600 v1).

Affected software

ProductAffectedFixed in
TP-Link System Inc.Archer BE230 v1.2Affected
  • =0
Fixed in
  • 1.2.4 Build 20251218 rel.70420
TP Link Systems Inc.Archer BE3600 v1Affected
  • =0
Fixed in
  • (USW)_V1.26_1.2.6 Build 20260617
  • (KR)_V1_1.2.2 Build 20260903
  • (EU)_V1_1.2.6 Build 20260617

AI-suggested

Organizations should immediately verify the firmware version of their TP-Link Archer BE230 devices and upgrade to version 1.2.4 Build 20251218 rel.70420 or later once available. If you cannot patch yet, restrict access to device management interfaces to trusted administrators only, ideally via out-of-band management or segmented networks. Enforce strong authentication mechanisms and regularly audit user accounts to prevent unauthorized access. Network segmentation should be implemented to limit adjacent network access to critical devices. Monitor device logs for unusual command execution or configuration changes that could indicate exploitation attempts. Disable unnecessary VPN modules or services if not in use to reduce attack surface. Additionally, implement network intrusion detection systems (NIDS) capable of identifying anomalous command injection patterns. Maintain an incident response plan that includes rapid isolation and remediation of compromised network devices.

Description

An OS Command Injection vulnerability in TP-Link Archer BE230 v1.2 and BE3600 v1 (vpn modules) allows adjacent authenticated attacker execute arbitrary code. Successful exploitation could allow an attacker to gain full administrative control of the device, resulting in severe compromise of configuration integrity, network security, and service availability. This CVE covers one of multiple distinct OS command injection issues identified across separate code paths. Although similar in nature, each instance is tracked under a unique CVE ID. This issue affects Archer BE230 v1.2 < 1.2.4 Build 20251218 rel.70420.

References

Community reviews

Loading reviews…