CVE-2026-22226: TP-Link Systems Archer BE230 v1.2 · OS Command Injection
Affects TP-Link Systems Archer BE230 v1.2Source CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 1.2.4 Build 20251218 rel.70420 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 2.5% chance of exploitation in 30 days – higher than 84% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.2.4 Build 20251218 rel.70420, 1.3.1 Build 20260430
CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Archer to 1.2.4 Build 20251218 rel.70420 (BE230 v1.2) or 1.3.1 Build 20260430 (AX73 v2).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TP-Link Systems Inc.Archer BE230 v1.2 | Affected
| Fixed in
|
| TP Link Systems Inc.Archer AX73 v2 | Affected
| Fixed in
|
AI-suggested
The description references fixed versions (Archer BE230 v1.2 >= 1.2.4 Build 20251218 rel.70420 and Archer AX73 v2 >= 1.3.1 Build 20260430), indicating that updating to these or later firmware versions should remediate the issue. Until official patches or updates are confirmed, restrict administrative access and monitor for suspicious activity. Verify with TP-Link's official advisories for the latest remediation instructions.
Description
A command injection vulnerability may be exploited after the admin's authentication in the VPN server configuration module on TP-Link Archer BE230 v1.2 and Archer AX73 v2. Successful exploitation could allow an attacker to gain full administrative control of the device, resulting in severe compromise of configuration integrity, network security, and service availability. This CVE covers one of multiple distinct OS command injection issues identified across separate code paths. Although similar in nature, each instance is tracked under a unique CVE ID. This issue affects Archer BE230 v1.2 < 1.2.4 Build 20251218 rel.70420 and Archer AX73 v2 < 1.3.1 Build 20260430.
References
- tp-link.com/us/support/download/archer-be230/v1.20/ (opens in a new tab)
- tp-link.com/en/support/download/archer-be230/v1.20/ (opens in a new tab)
- tp-link.com/sg/support/download/archer-be230/v1.20/ (opens in a new tab)
- tp-link.com/us/support/faq/4935/ (opens in a new tab)
- tp-link.com/us/support/download/archer-ax73/v2/ (opens in a new tab)
- tp-link.com/en/support/download/archer-ax73/v2/ (opens in a new tab)