Skip to main content
VulnerabilityPublished

CVE-2026-22248: glpi · Deserialization of Untrusted Data

Affects glpiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 11.0.5 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.5
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade glpi and glpi-project/glpi to 11.0.5.

Affected software

ProductAffectedFixed in
glpi-projectglpiAffected
  • >=11.0.0 <11.0.5
Fixed in
  • 11.0.5
GitHubglpi-project/glpipkg:github/glpi-project/glpiOther threatsAffected
  • <11.0.5 >=11.0.0
Fixed in
  • 11.0.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-22248, organizations should immediately upgrade GLPI installations to version 11.0.5 or later, where the vulnerability is fixed. Until the upgrade can be performed, restrict technician user privileges to the minimum necessary and monitor for suspicious file uploads or unusual activity from technician accounts. Implement strong authentication controls, including multi-factor authentication, to reduce the risk of credential compromise. Regularly audit user permissions and remove unnecessary technician accounts. Employ network segmentation and web application firewalls (WAFs) to limit exposure of GLPI servers to untrusted networks. Additionally, review and harden PHP configuration to disable unsafe deserialization functions if possible. Maintain comprehensive logging and alerting on file upload activities and deserialization errors to detect potential exploitation attempts early. Finally, educate administrators and users about the risks of deserialization vulnerabilities and the importance of timely patching.

Description

GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. From 11.0.0 to before 11.0.5, an authenticated technician user can upload a malicious file and trigger its execution through an unsafe PHP instantiation. This vulnerability is fixed in 11.0.5.

References

Community reviews

Loading reviews…