Skip to main content
VulnerabilityPublished

CVE-2026-22444: Apache Solr · Improper Input Validation

Affects Apache SolrSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High.

Data as of 26 Oct 2026, 09:16 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SolrAffected
  • >=8.6 <=9.10.0
Fixed in–
Mavenorg.apache.solr/solr-corepkg:maven/org.apache.solr/solr-coreOther threatsAffected
  • =8.6
  • <=9.10.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately verify if their Apache Solr deployments are running versions 8.6 through 9.10.0 and assess whether the 'create core' API is exposed to untrusted users. They must enable and properly configure the RuleBasedAuthorizationPlugin to restrict 'core-admin-edit' or equivalent permissions exclusively to trusted administrative roles, preventing unauthorized core creation. Upgrading to Apache Solr version 9.10.1 or later is critical to apply the official fix. Additionally, organizations should audit their 'allowPaths' settings to ensure they are correctly restricting filesystem access and review network exposure of Solr APIs, ideally limiting access via firewall rules or VPNs. On Windows systems, disabling UNC path support where not required or applying additional network segmentation can reduce the risk of NTLM hash exposure. Regular monitoring and logging of Solr API usage should be implemented to detect anomalous core creation attempts. Finally, organizations should conduct penetration testing and vulnerability scanning focused on Solr instances to confirm the absence of this vulnerability post-mitigation.

Description

The "create core" API of Apache Solr 8.6 through 9.10.0 lacks sufficient input validation on some API parameters, which can cause Solr to check the existence of and attempt to read file-system paths that should be disallowed by Solr's "allowPaths" security setting https://https://solr.apache.org/guide/solr/latest/configuration-guide/configuring-solr-xml.html#the-solr-element .  These read-only accesses can allow users to create cores using unexpected configsets if any are accessible via the filesystem.  On Windows systems configured to allow UNC paths this can additionally cause disclosure of NTLM "user" hashes.  Solr deployments are subject to this vulnerability if they meet the following criteria: * Solr is running in its "standalone" mode. * Solr's "allowPath" setting is being used to restrict file access to certain directories. * Solr's "create core" API is exposed and accessible to untrusted users.  This can happen if Solr's RuleBasedAuthorizationPlugin https://solr.apache.org/guide/solr/latest/deployment-guide/rule-based-authorization-plugin.html is disabled, or if it is enabled but the "core-admin-edit" predefined permission (or an equivalent custom permission) is given to low-trust (i.e. non-admin) user roles. Users can mitigate this by enabling Solr's RuleBasedAuthorizationPlugin (if disabled) and configuring a permission-list that prevents untrusted users from creating new Solr cores.  Users should also upgrade to Apache Solr 9.10.1 or greater, which contain fixes for this issue.

References

Community reviews

Loading reviews…