Skip to main content
VulnerabilityPublished Updated

CVE-2026-22771: envoyproxy gateway · Code Injection

Affects envoyproxy gatewaySource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 1.6.2 or 1.5.7 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.2, 1.5.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gateway to 1.6.2 or 1.5.7; envoyproxy/gateway to 1.5.7.

Affected software

ProductAffectedFixed in
envoyproxygatewayAffected
  • >=1.6.0-rc.0 <1.6.2
Fixed in
  • 1.6.2
envoyproxygatewayAffected
  • <1.5.7
Fixed in
  • 1.5.7
GitHubenvoyproxy/gatewaypkg:github/envoyproxy/gatewayOther threatsAffected
  • <1.5.7
Fixed in
  • 1.5.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Envoy Gateway to version 1.5.7 or later (including 1.6.2 or later) where this vulnerability is fixed. The Red Hat advisory confirms that these versions contain the official fix. No additional mitigation is required if these versions are deployed.

Description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.5.7 and 1.6.2, EnvoyExtensionPolicy Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. This vulnerability is fixed in 1.5.7 and 1.6.2.

References

Community reviews

Loading reviews…