CVE-2026-22778: vllm · Sensitive Data in Logs
Affects vllmSource CVE Database V5
Public exploit available (Metasploit) · 18% EPSS · CVSS 9.8 Critical : upgrade to 0.14.1 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 18.5% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.14.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: evidence found.
nuclei template: vLLM 0.8.3 - 0.14.0 - Information Disclosure
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vllm to 0.14.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of vLLM is available: version 0.14.1. Users should upgrade to vLLM 0.14.1 or later to remediate this vulnerability. No additional mitigations are indicated by the vendor advisories. Patch status is confirmed by Red Hat advisories linked in the vendor advisory content.
Description
vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-4r2x-xpjr-7cvv (opens in a new tab)
- github.com/vllm-project/vllm/pull/31987 (opens in a new tab)
- github.com/vllm-project/vllm/pull/32319 (opens in a new tab)
- github.com/vllm-project/vllm/releases/tag/v0.14.1 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-22778 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2436113 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-22778.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3461 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3462 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30089 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30088 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30087 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3782 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:19712 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3713 (opens in a new tab)