Skip to main content
CVE-2026-22792VulnerabilityPublished

CVE-2026-22792: nanbingxyz 5ire · Improper Encoding or Escaping of Output

Affects nanbingxyz 5ireSource CVE Database V5

0

Not known to be exploited · CVSS 9.7 Critical : upgrade to 0.15.3 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.7Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.15.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade 5ire and nanbingxyz/5ire to 0.15.3.

Affected software

ProductAffectedFixed in
nanbingxyz5ireAffected
  • <0.15.3
Fixed in
  • 0.15.3
GitHubnanbingxyz/5irepkg:github/nanbingxyz/5ireOther threatsAffected
  • <0.15.3
Fixed in
  • 0.15.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade of all 5ire installations to version 0.15.3 or later to apply the official fix. 2. Implement strict content security policies (CSP) to restrict execution of untrusted scripts within the application context. 3. Disable or limit the use of bridge APIs exposed to the renderer process unless absolutely necessary, applying the principle of least privilege. 4. Educate users about the risks of interacting with untrusted or unsolicited content within the 5ire application to reduce the likelihood of triggering the vulnerability. 5. Monitor network and application logs for suspicious activity related to MCP server creation or unusual API calls. 6. Employ endpoint detection and response (EDR) solutions to detect anomalous behavior indicative of exploitation attempts. 7. If upgrading immediately is not feasible, consider isolating 5ire usage to controlled environments or sandboxed sessions to limit impact. 8. Regularly review and audit third-party integrations and plugins within 5ire that might expose additional attack surfaces. 9. Coordinate with internal security teams to incorporate this vulnerability into threat hunting and incident response plans.

Description

5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Prior to version 0.15.3, an unsafe HTML rendering permits untrusted HTML (including on* event attributes) to execute in the renderer context. An attacker can inject an `<img onerror=...>` payload to run arbitrary JavaScript in the renderer, which can call exposed bridge APIs such as `window.bridge.mcpServersManager.createServer`. This enables unauthorized creation of MCP servers and lead to remote command execution. Version 0.15.3 fixes the issue.

References

Community reviews

Loading reviews…