CVE-2026-22801: pnggroup libpng · Out-of-bounds Read
Affects pnggroup libpngSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.6.54 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.54
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade libpng and pnggroup/libpng to 1.6.54.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pnggrouplibpng | Affected
| Fixed in
|
GitHubpnggroup/libpngpkg:github/pnggroup/libpngOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should take the following specific actions: 1) Identify all software and systems using libpng versions between 1.6.26 and 1.6.53, including third-party applications and embedded devices. 2) Prioritize upgrading libpng to version 1.6.54 or later, where the vulnerability is fixed. 3) For systems where immediate patching is not feasible, implement strict input validation and filtering to block PNG images with abnormal or suspicious row stride values, although this may be challenging. 4) Monitor application logs and system stability for crashes related to image processing components. 5) Employ application whitelisting and restrict local access to trusted users to reduce the risk of local exploitation. 6) Coordinate with software vendors to ensure timely updates and patches are applied. 7) Conduct security awareness training for staff with local system access to recognize and report suspicious activity. 8) Integrate vulnerability scanning tools that detect outdated libpng versions in the software inventory. These targeted measures go beyond generic advice by focusing on dependency management, input validation, and local access controls.
Description
CVE-2026-22801 is a medium severity vulnerability in libpng versions prior to 1.6.54, involving an out-of-bounds read caused by integer truncation in the simplified write API functions. Specifically, when a negative row stride or a stride exceeding 65535 bytes is provided, a heap buffer over-read occurs. This bug was introduced in libpng 1.6.26 due to casts intended to silence compiler warnings on 16-bit systems. The vulnerability affects applications that use libpng to read, create, or manipulate PNG images and can lead to denial of service due to application crashes. No known exploits are currently reported in the wild. The vulnerability requires local access to trigger (attack vector: local), does not require privileges or user interaction, and impacts availability primarily.