Skip to main content
VulnerabilityPublished

CVE-2026-22808: fleetdm fleet · Cross-site Scripting

Affects fleetdm fleetSource CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 4.78.2 : update fleetdm fleet when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.78.2, 4.77.1, 4.76.2 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade fleet to 4.78.2, 4.77.1, 4.76.2 or 4.53.3; fleetdm/fleet to 4.53.3.

Affected software

ProductAffectedFixed in
fleetdmfleetAffected
  • >=4.78.0 <4.78.2
Fixed in
  • 4.78.2
fleetdmfleetAffected
  • >=4.77.0 <4.77.1
Fixed in
  • 4.77.1
fleetdmfleetAffected
  • >=4.76.0 <4.76.2
Fixed in
  • 4.76.2
fleetdmfleetAffected
  • <4.53.3
Fixed in
  • 4.53.3
GitHubfleetdm/fleetpkg:github/fleetdm/fleetOther threatsAffected
  • <4.53.3
Fixed in
  • 4.53.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade fleetdm fleet installations immediately to versions 4.78.2, 4.77.1, 4.76.2, 4.75.2, or 4.53.3 or later, which contain the fix for this vulnerability.
  2. If immediate upgrading is not feasible, temporarily disable Windows MDM integration within fleet to prevent exploitation.
  3. Educate administrators to avoid clicking on untrusted links or visiting suspicious web pages while logged into the fleet management console.
  4. Implement Content Security Policy (CSP) headers to reduce the risk of XSS exploitation by restricting script sources.
  5. Regularly audit and monitor fleet logs for unusual administrative access patterns that could indicate token theft or misuse.
  6. Consider isolating fleet management consoles behind VPNs or restricted network access to reduce exposure to external attackers.
  7. Review and limit browser localStorage usage and consider token expiration policies to reduce the window of token misuse.

Description

CVE-2026-22808 is a medium severity cross-site scripting (XSS) vulnerability in fleetdm's open source device management software, fleet, affecting versions prior to 4.78.2, 4.77.1, 4.76.2, 4.75.2, and 4.53.

References

Community reviews

Loading reviews…