Skip to main content
CVE-2026-22813VulnerabilityPublished

CVE-2026-22813: anomalyco opencode · Cross-site Scripting

Affects anomalyco opencodeSource CVE Database V5

0

Not known to be exploited · CVSS 9.4 Critical : upgrade to 1.1.10 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade opencode and anomalyco/opencode to 1.1.10.

Affected software

ProductAffectedFixed in
anomalycoopencodeAffected
  • <1.1.10
Fixed in
  • 1.1.10
GitHubanomalyco/opencodepkg:github/anomalyco/opencodeOther threatsAffected
  • <1.1.10
Fixed in
  • 1.1.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade to OpenCode version 1.1.10 or later, where the vulnerability is patched. 2. Implement strict Content Security Policies (CSP) on the localhost web interface to restrict script execution sources and mitigate the impact of any injected scripts. 3. Integrate robust HTML sanitization libraries such as DOMPurify to cleanse any user or LLM-generated content before rendering it in the DOM. 4. Limit access to the OpenCode web interface to trusted users and networks, employing network segmentation and firewall rules to reduce exposure. 5. Educate developers and users about the risks of interacting with untrusted LLM responses and encourage verification of AI-generated content. 6. Monitor logs and network traffic for unusual activity related to the OpenCode interface, including unexpected script execution or data exfiltration attempts. 7. Consider running OpenCode in isolated environments or containers to contain potential exploitation impact. 8. Regularly review and update security configurations and dependencies to prevent similar vulnerabilities.

Description

CVE-2026-22813 is a critical cross-site scripting (XSS) vulnerability in the anomalyco OpenCode AI coding agent's markdown renderer. The renderer inserts arbitrary HTML into the DOM without sanitization or Content Security Policy (CSP), allowing JavaScript execution on the localhost web interface. This enables attackers who can influence the LLM response in a chat session to execute malicious scripts in the context of the http://localhost:4096 origin. The vulnerability affects OpenCode versions prior to 1.1.10 and requires no authentication but does require user interaction to trigger. Although no known exploits are currently in the wild, the high CVSS score of 9.4 reflects the severe impact on confidentiality, integrity, and availability. The issue is fixed in version 1.1.

References

Community reviews

Loading reviews…