CVE-2026-23497: frappe lms · Cross-site Scripting
Affects frappe lmsSource CVE Database V5
Not known to be exploited · CVSS 1.3 Low.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 14 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| frappelms | Affected
| Fixed in– |
GitHubfrappe/lmspkg:github/frappe/lmsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade Frappe LMS to a version later than 2.44.0 once a patch is released to fully remediate the vulnerability.
- Until an official patch is available, implement strict input validation and sanitization on filenames and other user-supplied inputs, ensuring that special characters and script tags are properly encoded or rejected.
- Employ Content Security Policy (CSP) headers to restrict the execution of inline scripts and reduce the impact of potential XSS attacks.
- Educate users about the risks of clicking on suspicious links or interacting with untrusted content within the LMS.
- Monitor LMS logs and user reports for unusual activity or signs of attempted exploitation.
- Consider isolating the LMS environment or restricting access to trusted users only, minimizing exposure.
- Conduct regular security assessments and code reviews focusing on input handling and output encoding to prevent similar vulnerabilities.
Description
CVE-2026-23497 is a stored cross-site scripting (XSS) vulnerability in Frappe Learning Management System (LMS) versions 2.44.0 and earlier. The flaw arises from improper neutralization of input, specifically in image filenames, which can lead to execution of malicious JavaScript when these filenames are rendered on course or jobs pages. Although the CVSS 4.0 score is low (1.3), the vulnerability does not require privileges or authentication but does require user interaction. No known exploits are currently reported in the wild. European organizations using Frappe LMS should be aware of this issue and apply mitigations to prevent potential exploitation, especially in environments where user-generated content is displayed. The impact is limited by the low severity and the need for user interaction, but stored XSS can still lead to session hijacking or defacement if exploited.