Skip to main content
VulnerabilityPublished Updated

CVE-2026-23694: Aruba HiSpeed Cache (WordPress plugin) · Cross-Site Request Forgery (CSRF)

Affects Aruba HiSpeed Cache (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 3.0.5 when convenient.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Aruba HiSpeed Cache (WordPress plugin) to 3.0.5.

Affected software

ProductAffectedFixed in
Aruba.itAruba HiSpeed CacheAffected
  • <3.0.5
Fixed in
  • 3.0.5

AI-suggested

Administrators should immediately update the Aruba HiSpeed Cache plugin to version 3.0.5 or later, where nonce verification is implemented to prevent CSRF attacks. If you cannot patch yet, organizations should implement additional protective measures such as enforcing strict Content Security Policy (CSP) headers to restrict cross-origin requests, educating administrators to avoid visiting untrusted websites while logged into WordPress admin accounts, and employing web application firewalls (WAFs) that can detect and block suspicious admin-ajax.php requests. Additionally, monitoring administrative actions and plugin configuration changes can help detect exploitation attempts. Disabling or limiting administrative access from untrusted networks and enforcing multi-factor authentication (MFA) for administrator accounts can further reduce risk. Finally, reviewing and hardening WordPress security settings and plugin permissions will help mitigate potential impact.

Description

Aruba HiSpeed Cache (aruba-hispeed-cache) WordPress plugin versions prior to 3.0.5 contain a cross-site request forgery (CSRF) vulnerability affecting multiple administrative AJAX actions. The handlers for ahsc_reset_options, ahsc_debug_status, and ahsc_enable_purge perform authentication and capability checks but do not verify a WordPress nonce for state-changing requests. An attacker can induce a logged-in administrator to visit a malicious webpage that submits forged requests to admin-ajax.php, resulting in unauthorized resetting of plugin settings, toggling of the WordPress WP_DEBUG configuration, or modification of cache purging behavior without the administrator’s intent.

References

Community reviews

Loading reviews…