Skip to main content
VulnerabilityPublished Updated

CVE-2026-23733: lobehub lobe-chat · Code Injection

Affects lobehub lobe-chatSource CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium : upgrade to 2.0.0-next.180 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.0-next.180
CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade lobehub lobe-chat to 2.0.0-next.180.

Affected software

ProductAffectedFixed in
lobehublobe-chatAffected
  • <2.0.0-next.180
Fixed in
  • 2.0.0-next.180
GitHublobehub/lobe-chatpkg:github/lobehub/lobe-chatOther threatsAffected
  • =2.0.0-next.180
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately verify their LobeChat versions and upgrade to 2.0.0-next.180 or later to apply the official patch. Beyond patching, organizations should implement strict privilege management to limit the number of users with high-level access to LobeChat instances. Employ application whitelisting and endpoint detection and response (EDR) solutions to monitor and block suspicious system command executions originating from LobeChat processes. Network segmentation can reduce the impact of a compromised host. Disable or restrict the electronAPI IPC bridge if possible, or apply additional sandboxing to limit its capabilities. Conduct user training to raise awareness about the risks of interacting with untrusted content within chat applications. Regularly audit and sanitize user-generated content to prevent injection of malicious scripts. Finally, monitor logs for unusual activity related to LobeChat usage and IPC communications.

Description

LobeChat is an open source chat application platform. Prior to version 2.0.0-next.180, a stored Cross-Site Scripting (XSS) vulnerability in the Mermaid artifact renderer allows attackers to execute arbitrary JavaScript within the application context. This XSS can be escalated to Remote Code Execution (RCE) by leveraging the exposed `electronAPI` IPC bridge, allowing attackers to run arbitrary system commands on the victim's machine. Version 2.0.0-next.180 patches the issue.

References

Community reviews

Loading reviews…