Skip to main content
VulnerabilityPublished

CVE-2026-23735: graphql-modules · Race Condition

Affects graphql-modulesSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 3.1.1 or 2.4.1 soon.

Data as of 26 Oct 2026, 09:16 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.1, 2.4.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade graphql-modules and graphql-hive/graphql-modules to 3.1.1 or 2.4.1.

Affected software

ProductAffectedFixed in
graphql-hivegraphql-modulesAffected
  • >=2.2.1 <2.4.1
  • >=3.0.0 <3.1.1
Fixed in
  • 3.1.1
  • 2.4.1
GitHubgraphql-hive/graphql-modulespkg:github/graphql-hive/graphql-modulesOther threatsAffected
  • >=2.2.1 <2.4.1
  • >=3.0.0 <3.1.1
Fixed in
  • 2.4.1
  • 3.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately identify any deployments of graphql-hive graphql-modules within the affected version ranges (>=2.2.1 and <2.4.1, >=3.0.0 and <3.1.1). The primary mitigation is to upgrade to patched versions 2.4.1 or 3.1.1 as soon as possible. If immediate upgrade is not feasible, organizations should implement strict request serialization or limit concurrency on services using @ExecutionContext() to reduce the risk of context mixing. Additionally, review and enhance logging and monitoring around GraphQL API requests to detect anomalous access patterns or context leakage. Employ runtime application self-protection (RASP) or web application firewalls (WAF) with custom rules to monitor and potentially block suspicious concurrent request patterns. Conduct thorough code reviews to ensure proper synchronization when handling shared resources in custom modules. Finally, enforce strict token scopes and short token lifetimes to minimize the impact of any leaked authentication context.

Description

CVE-2026-23735 is a high-severity race condition vulnerability in graphql-hive's graphql-modules versions 2.2.1 to before 2.4.1 and 3.0.0 to before 3.1.1. The flaw occurs when multiple parallel requests trigger the same service, causing request contexts—often containing sensitive authentication tokens—to be mixed up due to improper synchronization in the @ExecutionContext() injection.

References

Community reviews

Loading reviews…