Skip to main content
CVE-2026-23839VulnerabilityPublished Updated

CVE-2026-23839: leepeuker movary · Improper Input Validation

Affects leepeuker movarySource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.70.0 as a priority.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.70.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade movary and leepeuker/movary to 0.70.0.

Affected software

ProductAffectedFixed in
leepeukermovaryAffected
  • <0.70.0
Fixed in
  • 0.70.0
GitHubleepeuker/movarypkg:github/leepeuker/movaryOther threatsAffected
  • <0.70.0
Fixed in
  • 0.70.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade all Movary instances to version 0.70.0 or later, where the vulnerability is fixed. 2. Implement strict input validation and output encoding on all user-supplied data, especially URL parameters like `categoryUpdated`, to prevent injection of malicious scripts. 3. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. 4. Conduct regular security audits and penetration testing focusing on input validation and XSS vectors within the application. 5. Educate users and administrators about phishing risks and the dangers of clicking untrusted links that may exploit this vulnerability. 6. Monitor web server and application logs for unusual requests containing suspicious payloads targeting the vulnerable parameter. 7. If upgrading immediately is not feasible, consider implementing web application firewall (WAF) rules to detect and block malicious input patterns targeting the `categoryUpdated` parameter. 8. Review session management practices to ensure that session tokens are protected via HttpOnly and Secure flags to mitigate session hijacking risks.

Description

Movary is a web application to track, rate and explore your movie watch history. Due to insufficient input validation, attackers can trigger cross-site scripting payloads in versions prior to 0.70.0. The vulnerable parameter is `?categoryUpdated=`. Version 0.70.0 fixes the issue.

References

Community reviews

Loading reviews…