Skip to main content
CVE-2026-23840VulnerabilityPublished

CVE-2026-23840: leepeuker movary · Improper Input Validation

Affects leepeuker movarySource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.70.0 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.70.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade movary and leepeuker/movary to 0.70.0.

Affected software

ProductAffectedFixed in
leepeukermovaryAffected
  • <0.70.0
Fixed in
  • 0.70.0
GitHubleepeuker/movarypkg:github/leepeuker/movaryOther threatsAffected
  • <0.70.0
Fixed in
  • 0.70.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all instances of movary to version 0.70.0 or later to remediate the vulnerability. In addition to patching, implement strict input validation and output encoding on all user-supplied data, especially URL parameters like `categoryDeleted`. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. Conduct regular security audits and penetration testing focused on input validation weaknesses. Educate users about the risks of clicking on suspicious links and monitor web application logs for unusual activity related to the vulnerable parameter. Deploy web application firewalls (WAFs) with rules designed to detect and block XSS payloads targeting movary. Finally, maintain an incident response plan that includes procedures for handling XSS incidents and potential data breaches.

Description

CVE-2026-23840 is a critical cross-site scripting (XSS) vulnerability in the leepeuker movary web application, affecting versions prior to 0.70.0. The issue arises from improper input validation of the `? categoryDeleted=` parameter, allowing attackers to inject malicious scripts. Exploitation requires user interaction but no authentication, and can lead to full compromise of user confidentiality and integrity. The vulnerability has a CVSS score of 9.3, indicating a severe risk. Although no known exploits are currently in the wild, unpatched instances remain at high risk. European organizations using movary for movie tracking and rating should prioritize upgrading to version 0.

References

Community reviews

Loading reviews…