Skip to main content
VulnerabilityPublished Updated

CVE-2026-23841: leepeuker movary · Improper Input Validation

Affects leepeuker movarySource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.70.0 as a priority.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.70.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade movary and leepeuker/movary to 0.70.0.

Affected software

ProductAffectedFixed in
leepeukermovaryAffected
  • <0.70.0
Fixed in
  • 0.70.0
GitHubleepeuker/movarypkg:github/leepeuker/movaryOther threatsAffected
  • <0.70.0
Fixed in
  • 0.70.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all affected Movary instances to version 0.70.0 or later, where the vulnerability is patched. In addition to patching, implement strict input validation and output encoding on all user-supplied data, especially URL parameters such as 'categoryCreated'. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Conduct thorough security testing, including automated scanning and manual code reviews, to detect similar input validation issues. Educate users about the risks of clicking on suspicious links and encourage cautious behavior to reduce the likelihood of successful social engineering attacks. Monitor web application logs for unusual requests targeting the vulnerable parameter and set up alerts for potential exploitation attempts. Consider deploying Web Application Firewalls (WAFs) with rules to detect and block XSS payloads targeting Movary. Finally, maintain an incident response plan to quickly address any exploitation events.

Description

Movary is a web application to track, rate and explore your movie watch history. Due to insufficient input validation, attackers can trigger cross-site scripting payloads in versions prior to 0.70.0. The vulnerable parameter is `?categoryCreated=`. Version 0.70.0 fixes the issue.

References

Community reviews

Loading reviews…