Skip to main content
VulnerabilityPublished Updated

CVE-2026-23864: Meta react-server-dom-webpack · : Deserialization of Untrusted Data.: Uncontrolled Resource Consumption

Affects Meta react-server-dom-webpackSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High · fixed in 19.2.4 : patch Meta react-server-dom-webpack soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.5% chance of exploitation in 30 days – higher than 85% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.2.4, 19.1.5, 19.0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade react-server-dom-webpack and react-server-dom-turbopack and react-server-dom-parcel to 19.2.4, 19.1.5 or 19.0.4.

Affected software

ProductAffectedFixed in
Metareact-server-dom-webpackAffected
  • >=19.2.0 <19.2.4
Fixed in
  • 19.2.4
Metareact-server-dom-webpackAffected
  • >=19.1.0 <19.1.5
Fixed in
  • 19.1.5
Metareact-server-dom-webpackAffected
  • >=19.0.0 <19.0.4
Fixed in
  • 19.0.4
Metareact-server-dom-turbopackAffected
  • >=19.2.0 <19.2.4
Fixed in
  • 19.2.4
Metareact-server-dom-turbopackAffected
  • >=19.1.0 <19.1.5
Fixed in
  • 19.1.5
Metareact-server-dom-turbopackAffected
  • >=19.0.0 <19.0.4
Fixed in
  • 19.0.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has issued security advisories and errata that include fixes for this vulnerability. Users should upgrade to the latest package versions that address CVE-2026-23864 to mitigate the risk. Since this is not a cloud service, remediation depends on applying these updates. Patch status is confirmed via Red Hat advisories linked in the vendor advisory content. No additional vendor advisory states that no action is required.

Description

Multiple denial of service vulnerabilities exist in React Server Components, affecting the following packages: react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack. The vulnerabilities are triggered by sending specially crafted HTTP requests to Server Function endpoints, and could lead to server crashes, out-of-memory exceptions or excessive CPU usage; depending on the vulnerable code path being exercised, the application configuration and application code. Strongly consider upgrading to the latest package versions to reduce risk and prevent availability issues in applications using React Server Components.

References

Community reviews

Loading reviews…