CVE-2026-23897: apollographql apollo-server · ReDoS
Affects apollographql apollo-serverSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 5.4.0 or 4.13.0 soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.4.0, 4.13.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade apollographql apollo-server to 5.4.0 or 4.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| apollographqlapollo-server | Affected
| Fixed in
|
AI-suggested
European organizations should immediately audit their use of Apollo Server to determine if they use the startStandaloneServer default configuration in affected versions. If so, they should upgrade Apollo Server to versions later than 3.13.0, 4.13.0, or 5.4.0, where this vulnerability is resolved. If upgrading is not immediately feasible, organizations should consider migrating from standalone server usage to integration packages such as @as-integrations/express5 or @as-integrations/next, which are not affected by this vulnerability. Implementing Web Application Firewalls (WAFs) with rules to detect and block suspicious GraphQL requests containing exotic character set encodings can provide temporary protection. Rate limiting and IP reputation filtering can reduce the risk of DoS attacks. Monitoring server performance metrics and setting up alerts for unusual CPU spikes can help detect exploitation attempts early. Additionally, organizations should review their incident response plans to include scenarios involving GraphQL service disruptions. Finally, keeping dependencies up to date and subscribing to Apollo Server security advisories will help maintain ongoing protection.
Description
Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.
References
- github.com/apollographql/apollo-server/security/advisories/GHSA-mp6q-xf9x-fwf7 (opens in a new tab)
- github.com/apollographql/apollo-server/commit/d25a5bdc377826ad424fcf7f8d1d062055911643 (opens in a new tab)
- github.com/apollographql/apollo-server/commit/e9d49d163a86b8a33be56ed27c494b9acd5400a4 (opens in a new tab)