Skip to main content
VulnerabilityPublished

CVE-2026-23982: Apache Superset · Incorrect Authorization

Affects Apache SupersetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 6.0.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Superset and apache-superset to 6.0.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SupersetAffected
  • <6.0.0
Fixed in
  • 6.0.0
PyPIapache-supersetpkg:pypi/apache-supersetOther threatsAffected
  • <6.0.0
Fixed in
  • 6.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade Apache Superset to version 6.0.0 or later immediately, as this version contains the fix for the improper authorization vulnerability.
  2. Restrict dataset write permissions to only trusted and necessary users to minimize the attack surface.
  3. Implement strict role-based access controls (RBAC) and regularly audit user permissions to ensure least privilege principles.
  4. Monitor logs for unusual dataset modifications or SQL query changes that could indicate exploitation attempts.
  5. Employ network segmentation and firewall rules to limit access to the Superset instance to authorized personnel only.
  6. Consider deploying Web Application Firewalls (WAF) with custom rules to detect and block suspicious SQL query manipulations.
  7. Educate administrators and users about the risks of improper authorization and the importance of following security best practices.
  8. Regularly review and update security policies related to data access and application usage.
  9. If upgrading immediately is not feasible, consider temporarily disabling dataset write permissions or restricting access to critical datasets until patched.

Description

An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

References

Community reviews

Loading reviews…