CVE-2026-23984: Apache Superset · Incorrect Authorization
Affects Apache SupersetSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 6.0.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache Superset and apache-superset to 6.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Superset | Affected
| Fixed in
|
PyPIapache-supersetpkg:pypi/apache-supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade Apache Superset to version 6.0.0 or later immediately, as this version contains the fix for the authorization bypass issue.
- Review and restrict SQLLab access permissions to only trusted users, minimizing the number of users who can exploit this vulnerability.
- Implement strong authentication and monitoring for Superset users, including multi-factor authentication and logging of SQLLab activities to detect suspicious DML attempts.
- Conduct regular audits of database changes originating from Superset to identify unauthorized modifications promptly.
- If upgrading is temporarily not possible, consider disabling SQLLab or restricting PostgreSQL connections to trusted users only, or enforce database-level read-only roles as an additional control.
- Educate users about the risks of executing arbitrary SQL commands and enforce least privilege principles.
- Monitor Apache Superset and PostgreSQL logs for anomalous SQL statements that could indicate exploitation attempts.
Description
An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.