Skip to main content
VulnerabilityPublished

CVE-2026-24006: lxsmnsyc seroval · Unthrottled Resource Allocation

Affects lxsmnsyc serovalSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 1.4.1 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade seroval and lxsmnsyc/seroval to 1.4.1.

Affected software

ProductAffectedFixed in
lxsmnsycserovalAffected
  • <1.4.1
Fixed in
  • 1.4.1
GitHublxsmnsyc/serovalpkg:github/lxsmnsyc/serovalOther threatsAffected
  • <1.4.1
Fixed in
  • 1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade all instances of the lxsmnsyc seroval library to version 1.4.1 or later, which includes the depthLimit parameter to prevent excessive recursion.
  2. Implement strict input validation and sanitization to limit the depth and complexity of objects accepted for serialization.
  3. Employ runtime monitoring and anomaly detection to identify unusual serialization patterns or crashes indicative of exploitation attempts.
  4. Integrate automated dependency management tools to track and update vulnerable libraries promptly.
  5. Conduct code reviews and security testing focusing on serialization logic and resource consumption.
  6. Where upgrading is not immediately feasible, consider sandboxing or isolating components that perform serialization to contain potential crashes.
  7. Educate developers about secure serialization practices and the risks of processing untrusted data without limits.

Description

CVE-2026-24006 is a high-severity vulnerability in the lxsmnsyc seroval library versions prior to 1.4.1. The issue arises from the lack of limits on resource allocation during serialization of deeply nested JavaScript objects, leading to potential stack overflow and denial of service. The vulnerability does not impact confidentiality or integrity but can cause application crashes, affecting availability. Exploitation requires no privileges or user interaction and can be triggered remotely by processing crafted input. The vulnerability was addressed in version 1.4.1 by introducing a depthLimit parameter that throws an error when exceeded. European organizations using vulnerable versions of seroval in their software stacks, especially those handling complex data serialization, are at risk.

References

Community reviews

Loading reviews…